Problem with Downloading Patches from Forum on iOS

download
ipad

#1

I’m looking for a fix for this right now and should have it solved soon.

This is just a notice to report that some people are having trouble downloading patch files from the forum on iOS.

Instead of opening the patch files in Audulus, they will open as a window of code in your browser.

Some people have gotten around this by saving the code as a text file and changing the file extension from .txt to .audulus, and @RileyGuy below says he’s able to save into Dropbox and open from there, but this isn’t an acceptable long term solution.

For now, it might be easiest to just download patches on your computer and drop them in your iCloud drive or transfer them directly to your iPad.

Sorry for the inconvenience!

UPDATE: I’ve contacted Discourse and they’re working on a fix for this. Will let you know more in the post below when I know more!


#3

Any possible update to this issue or is changing the file extension of the downloaded code going to be the only way to get forum patches on the ipad for the time being if not near a computer at the time?


#4

We’re talking to Discourse support - it’s something they have to change on their end. I’ll let you know as soon as I know anything from them! :slight_smile:


#5

Thanks! Looks like I can easily save to Dropbox and then just load the patch from there on my iPad (without using the computer) and it seems to be working smoothly!


#6

I just got word back from Discourse Staff - they have a guy working on it now. He also happens to be into modular synths, so hopefully we’ll see him over here at our forum sometime!


#7

Saving to Dropbox and then importing to Audulus 3 worked for me on iOS for now.


#8

Good to know! Thanks :slight_smile:


#9

Alternate Method to Download Audulus Patches on iOS

  1. Long press on the forum website patch link to get a copy of it
  2. Open an app like Documents or GoodReader
  3. Paste the link into their browser
  4. Download the file
  5. Change the name to FileName.audulus rather than FileName.txt
  6. Save the file to a location on the iPad or your iCloud Drive

#10

Here’s another workaround for downloading files on iOS using the Workflow app (which is generally a very useful app to have on iOS and is free on the App Store).

  1. Download the ‘Download File’ workflow from the Workflow gallery within the app.
  2. Tapping the download file icon on the forum opens the file as a text file in a new tab in your browser.
  3. Select the workflow from the share sheet.
  4. From there you can select where you’d like to download it to – the iCloud Drive Audulus folder or one of its subfolders, Dropbox, etc.


#11

This is the easiest download workaround so far.


#12

Getting an error when trying to use workflow


#13

Was that the Zip with all the old forum patches you were trying to download?


#14

Yes, it was


#15

The Workflow workflow is just for downloading single files. You should be able to see the code as a text file in your browser – see my screenshot above.

For ZIpped files like the old forum collection no workflow is needed (although you can use workflow to Zip and Unzip files). Since the collection is 140 Mb though it can take a while to download (depending on your connection) and Safari on iOS isn’t that good at indicating download status. Simply give it some time and after a while the Zippped collection should appear, and can then be saved to the location you choose. (I got an error when trying to save to Dropbox, but it saved without problem to iCloud Drive.)


#16

Still waiting to hear back from Discourse about getting this fixed…will keep everyone updated!


#17

Latest word from Discourse:

I’ve been trying to get it to work, but am not having any luck yet. I’ll look at it some more and then post in the public topic that you created on meta.discourse. Hopefully someone will have an idea what’s going on. I can download audulus files on Android without any problem, so the issue is something specific to the way iOS interacts with Discourse.


#18

Latest from Discourse:

I have Audulus on my iPad, so I’ve looked at this a bit. Audulus files can be downloaded on an iPad by quick pressing the download link. This opens the file and displays it on the screen. The file can then be saved and opened in Audulus. The other thing that works is to long press the link and then select Open, or Open in New Tab, from the options menu. Doing this displays the file on the screen in the same way as when the link is quick pressed. It can then be saved and later opened in Audulus. I’m saving the files to Dropbox. When the file is saved, the .audulus file extension is preserved. I’ve tested this with links from here: https://forum.audulus.com/ I haven’t found any way to open a file directly in Audulus without first saving it.

In other words, what other people have already suggested in the forum topic above.

Hopefully we’ll get a better answer about this soon. There’s clearly something different about the way Discourse is handling files that prevents the “Open in Audulus” option from showing up. Their customer service has been really great so far on a lot of things, so I’m hoping that will extend to this problem as well.


#19

I did some more digging today and determined that the MIME type for .audulus files is set incorrectly. When I download a .audulus file from the Forum, the MIME type in the response header is text/html; charset=utf-8. For a zip file the MIME type is application/zip which is what you would expect. The MIME type should probably be application/octet-stream or possibly application/json. iOS is actually doing exactly what it should. Discourse is telling the browser that it is sending text, so Safari on iOS displays it. What is interesting is that Safari on macOS works. Firefox on macOS also shows the file as a binary file even though it’s MIME is text. I know that Firefox has some code that attempts to guess file type from the file content and I guess macOS Safari does also. Somewhere in Discourse is a table that maps file extensions to MIME types or some other mechanism for setting the MIME type which obviously knows nothing about .audulus files.


#20

My bad. Was actually looking at the header for the service worker that actually downloads the file which is HTML. The MIME for the actual file download is application/octet-stream


#21

So it looks like it will be at least a 2-3 months before this problem is fixed for iOS. I’m really sorry I don’t have a better answer. In the meantime, either download the patches on your computer and send them to your iOS device through file transfer or iCloud, or use one of the stated workarounds above.

Thank you! I will update everyone when I know more.