Uplifting Ceremony


Uplifting Ceremony.audulus (1.1 MB)

2 Likes

Tx for posting the audio example. I find if helpful.

2 Likes

What do I need to initiate playback? Turning on the clock doesn’t seem to get it running – and I wasn’t able to quickly grok the patchflow enough to see what else needs to be done.

Tx. Love the demo track’s almost Drexciya-like vibe.

1 Like

I am not sure what the issue could be. I downloaded the patch, pressed start on the clock, and everything runs. Sometimes Audulus crashes in iOS and I have to just kill it and open it again.

Drexciya? Nice compliment, thanks.

1 Like

Rebooting the iPad solved the problem.

2 Likes

I think at some point we might hold @taylor’s feet to the fire as far as the crashing goes. Audulus has been one of the greatest things I have seen on planet earth, but as things get more complicated with production, software needs to somehow really get as tight as a hardware synth. Personally, I am not as interested in features as I am in reliability. This may be just because I am so new to synth techniques that I could probably work with A3 for years. At the same time, I understand that features sell software and I am just so damn grateful he even made the program in the first place. It is more than adequate for production, but I would not trust it live unless I had 3 or 4 other machines I could count on if it dropped out.

Audulus 4 should be very very stable, given the new architecture :). Of course there will be bugs we’ll have to work out at first.

3 Likes

In this case, the app itself isn’t crashing but the signal path seems to die. it is really strange. The u.i. works but LEDs and signal indicators inside Audulus behave as there is no signal. Toggling the background audio setting seems to fix things when they get into this state sometimes.

1 Like

Any guesses as to whether A4 is something we might see before or after summer (in North America).

I wasn’t able to replicate the issue. Does the clock run when you start it?

When this bug raises its head, no LEDs or signals work. I think this is a known issue, but I hadn’t run into it in quite a while and so forgot about it.

1 Like

If i can make it happen again, I’ll post a video.

2 Likes

Here is the problem in action

Interesting. Does it occur if Audulus is the only running application or only if AUM is also launched? The audio engine is obviously hung for some reason.

AUM is unrelated. It’ll happen if AUM has never run. It turns out that AUM happens to be the only way to get the audio going again that I know of without power-cycling the iPad. It only happens with one of Background Audio active or inactive. I

I think that @taylor knows about the issue. It

I’ve seen it happen before. My guess is it’s a bug in AVAudioEngine, which is generally a piece of crap. Hopefully Apple will fix that someday. But it’s amateur hour over there: I filed a bug report crashing AVAudioEngine in two lines of code and the clown on the other end said it was my fault for calling the functions in the wrong order… which is of course what I did deliberately to show what a pice of shit it is.

3 Likes