Problem with Downloading Patches from Forum on iOS

I got back in touch with the Discourse people and will let y’all know when I hear something from them! :slight_smile:

1 Like

Thanks Robert, got it to work with Workflow.

2 Likes

In iOS 12, the Workflow app has been updated and renamed to Shortcuts.

4 Likes

Thanks, I’m still trying to get them to get a more permanent solution…

what a fiasco

I just discovered that problem, but as mentioned before there are iOS browsers that allow downloads, from where one can ‘open-in’ the files into Audulus. I’m using Firefox.

1 Like

Hold link > Copy > Open Files > Open On My iPad > Open Audulus 3 Folder > Paste

Open Files > On My iPad > Firefox > Downloads > Share > Save to Files > Audulus 3 Folder

Open Files > On My iPad > Firefox > Downloads > Drag and Drop to Audulus 3 Folder

3 Likes

It seemed like for a while that, maybe by some iOS update, Audulus files just plain loaded automatically without the above runarounds. Well, now it seems to force a .txt on the end. Anyone know how to get iOS to stop adding the .txt?

This is a question I had brought up a couple months ago. I will try to find it and repost here. :slightly_smiling_face:

This is where I brought up the fact that it was happening with my Mac, also. The reported solution was to use a different browser for Mac, and to use the Shortcuts app for downloads on the iPhone, as it seems to be a result of the discourse server’s reporting of the MIME types, combined with a Safari security feature, from what I understand, anyway.

I would suggest you try to download from the forum with another iPhone web browser, and if that doesn’t help, just use the iPhone/iPad Shortcuts with the settings that @Paulinko suggested in that thread, until the MIME types debacle gets sorted out. Wish I had better news for you. :confused:

For Safari in preferences/general there is a setting for download location. If you set it to ask for each download you can backspace over the .txt extension before saving the file.

2 Likes

I tried ‘settings>safari>general>downloads’ on iOS and all I get is an option to choose between the download location of my device or the location of icloud. I do not see the option to ask for each download. On another note, for a while (maybe a month or two – maybe because of an iOS update) it all just worked. I would download an audulus patch on my device and Audulus would just load it automatically.

Also, if I try to rename the document in Audulus, I can’t see the extensions.

The tip was for macOS. @stevo3985 mentioned the downloads directory which is only for macOS. The best solution I’ve found for iOS is the shortcuts app mentioned above.

The stickied guide to using the app Shortcuts, is now a bit flawed (since iOS 13). The “Download file” shortcut comes up on the vertical share list and not on the horizontal list of apps. There were also a few other inconsistancies, so as it is, the guide is more likely to confuse people.

I have fallen into the runaround habit of sending to dropbox–>renaming(deleting .txt)–>exporting to Audulus. Feels like a bad habit, but it works for me.

Hey @LarsDaniel! I think there are a few different places throughout the forum where the Shortcuts script is mentioned, and it had to be fixed/adjusted along the way due to changing iOS browser display and interaction behavior, like what you just mentioned.

!!! 2020/12/02 TESTED FIX HERE !!!

For anyone having trouble with (the infuriating issue of) .txt being appended to iOS module/patch files from the forum:

If you follow the link at the bottom of this post, you can download the script (which I just tested again to take the displayed screenshots included for anyone who prefers visual instructions) into Shortcuts. Once you have the Shortcuts script, it should appear by default in your Safari Share Menu options (I can only vouch for Safari, as I don’t typically use any other browser on iPad/iPhone), where you can move it up or down the list as you see fit. Once you have that, click any desired [module or patch].audulus file, skip ‘Download’ and select ‘View’ instead. When it opens to the text file, click the share sheet icon in the navigator bar at the bottom and select ‘Download File’. You will see the script begin to execute, and then a screen will appear indicating that Files is going to save the downloaded module. You can rename it by selecting the name of the file next to the picture if you want, then select the location where you want it to go, and the script will dump it there when you click Save. No more complex, multi-app or multi-system shuffle necessary any longer!

3 Likes

This just saved me. Boy was I lost. My old workaround dried up for some reason.

1 Like

@futureaztec I’m always quite happy to be of assistance wherever I am able and really glad that the link and instructions update turned out to be useful for you :partying_face:

I hope others will also be able to easily find this. I tried to make that post :arrow_up: as visible as possible in this thread, as I realized when @LarsDaniel mentioned it, just because the location of my fix in a different thread seemed obvious to me, that does not mean that others will magically be able to find it and know it is the up to date and validated fix for the iOS download issue.

I once saw @biminiroad pin an important (maybe the loss of support for Windows and Linux thread?) announcement to the front page so everyone would see it first thing. If @stschoen or @robertsyrett have the power to do so for this, that might be the most beneficial way for everyone to be able to find it. I can make sure it stays updated if that can be done. Please let me know if there is anything else I can do! :smiley:

I’m pretty sure I can pin a post to the main page but I think it would be better if you created a new post rather than pin this one, since you would need to scroll through a lot of older information to reach your recent contributions.

1 Like

That’s a really good point. I will make a fresh post of it all, and if you could pin that one, I will make sure to keep it up to date for the forum. :slightly_smiling_face:

3 Likes