Microphone Node?

Is there a trick to using the microphone node? I have tried making several patches lately using the microphone in iOS and MacOS A3, and no dice for me :confused: Is anyone else having this issue? I even tried using @stschoen’s vocoder patch, which I know for a fact is not going to fail like my daydream “should be focused on finding lunch, but here I am analyzing synth science in my head” half baked theoretical concept of using external sounds to create numerical values that I can feed a phaser or oscillator node, but that is not working for me either. :frowning:

External Audio Controlled Synth.audulus (66.1 KB)

16 band vocoder V1.1.audulus (1021.2 KB)

The microphone and speaker nodes are a legacy from an earlier version of Audulus that only supported two channels of audio. When multi-channel audio was introduced the ADC and DAC nodes were introduced. The mic node represents input channels 1 and 2 from whatever input source is currently active. The label is a bit misleading because depending on your audio setup it may not be connected to the mic at all. If you have an external audio interface connected on iOS or selected as your input source in macOS then it will be connected to the interface. It would probably be better to use the ADC node since the mic node will probably be deprecated at some point.


@stschoen Ok, so I’ve tested based on what you pointed out, and you’re right (not that I doubted, just preface to the rest of my inquiry), it does work (OS X, anyway) with the ADC nodes for channel 1&2, however, that same setup does not work on iPad or iPhone.

The nearest conclusion I can come to is that A3 maybe doesn’t have any way to tell the OS now (since the Apple updates that changed a lot of audio issues we had been having previously) that the hardware microphone is needed, and so it is not activated.

This could be why the BT 4.0+ headphones have started working, since the issue I researched back in December 2018 seemed to have the microphone always on, and now it is off, and so now it is not trying to use a whole channel for input and only leaving a single channel for all output, even when no microphone was necessary, in previous use cases.

Do you have any suggestions about things I might be missing that could make the microphone trigger and make the ADC nodes for ch 1&2 for input work? I have attached the patch I just attempted to us on my iPad and iPhone just a few minutes ago for you or anyone else to take a look at, just in case I’ve wired something wrong. Your original version had just the single :microphone: node, and so I sub’d in the ADC’s where I thought they would work the same. Thanks! :slightly_smiling_face:

16 band vocoder V1.1.audulus (1021.5 KB)

I’ve tested both the mic node and the ADC node on my iPad Air2 and iPhone 8. and they both work. The internal mic is wired to ADC channel 1 or if you’re using the mic node it’s the lower output. I’m running the current iOS release on both devices. This is with no other audio device connected. I also tested the iPad and the iPhone 8 with a set of stereo headphones without a mic connected. For the iPhone 8 I used the Apple provided adapter. I also test a set of Skullcandy and Hypergear bluetooth earbuds on the iPad with mic which also worked.
The best way to tell if you have an active signal on the mic is to connect the ADC node directly to a waveform display node. You’ll be able to see the signal if one is present.
In your patch you have the external carrier input enabled and connected to ADC node 2. Since that node is not connected when using the internal mic, you will have no carrier and therefore no sound from the vocoder. Normally the carrier is some type harmonically rich sound input from an instrument such as a synth or guitar or you can use the internal carrier if the external switch is off. You might need to add some gain to the mic. The level control at max provides a 6 dB gain.

1 Like

Well, I managed to get the ADC node working with my iPhone. I guess I had the meter wired to channel 2, which I didn’t realize and I know now will not do what I want it to do. I don’t know what the deal is with my iPad, however, as it will not work at all. It is like the microphone is disabled. But then again, this is not the first time we have had issues noticed with an iPad Pro vs. the iPad Air 2, which seems to work just fine, and I also have, but it is currently serving as my development unit.

I don’t think I can determine anything reliably with a beta build of the OS that is not yet openly available to the general public. I will figure out more about this when I have more energy to care, but right now, I am more concerned with how I am going to pack up all of my things and move from Chicago to Seattle in a month for a new job opportunity. Thanks for your help @stschoen :smile:

No problem. :cowboy_hat_face: Good luck with the move, and the new job. That’s a major relo. I haven’t loaded the iOS 13 beta as yet. Too many opportunities for things to break. I do have macOS Catalina loaded on an external drive on my Mac. I haven’t had the time to play with it very much and I have a few 32 bit apps that won’t run so I’m holding off on switching my main boot drive over.

1 Like