MacOS MIDI Not Recognized By Audulus

MIDI Just Stopped Working with Audulus


Hey guys, I have been having some trouble today and I don't know where to go from here, as my troubleshooting steps have led me to the conclusion that something strange is happening with Audulus 3, currently on my Mac. I built the patch I have attached at the bottom of the post here. Then when I wanted to test it out, I had Logic Pro running, and wondered why the sound was different than what it should be in the tutorial. Once I realized that LP was running, I shut that down, but I had noticed it odd that no signal messages appeared to be flowing from my MIDI keyboard node in the patch, but thought nothing of it until I realized it was not passing MIDI control signals in Audulus.

I rebooted my Mac, still no dice. Plugged and unplugged the keyboard, started the MIDI setup utility and verified that my MAC is indeed getting signals, verified by the beep as each key was released. I re-opened LP and made sure that I wasn't going crazy, and the MIDI signals work fine in that app. It appears to just be Audulus doing this, which really sucks, because my iPad is dead right now, and I was feeling super motivated and creative today, but half of my workflow is now not functioning, so there is a limited amount I am able to do. Can anyone offer any advice or tell me what could be causing this?


Electric Piano Clone.audulus (20.9 KB)
1 Like

Try going inside the MIDI module and setting the channel to Omni instead of channel 1?

1 Like

Thanks for replying. I should have mentioned that I set it to omni, then in the process of my testing, I attempted all 16 channels. I must have mistakenly saved the channel 1 setting when I exited Audulus. Also forgot to mention I have already deleted and reinstalled Audulus, still no change has happened. That’s when I decided to post here because I am so clueless where to go next… :slightly_frowning_face:

1 Like

Try this? I just replaced the MIDI input and the audio output, seems to work fine for me.

Electric Piano Clone - fixed maybe.audulus (43.5 KB)

1 Like

Unfortunately, that is not working for me either. Trying now to open the Audulus AU in Logic to see if it will work there, at the very least. Man this is really frustrating!

1 Like

I’m sorry nothing sucks more than fighting the gear. It sounds though like you have a problem with the MIDI controller - maybe double check the settings, or do a factory reset if you wouldn’t lose valuable mapping data?

1 Like

None of my other synths are effected though, and the Audulus AU still works perfectly in Logic. I also had done a factory reset of my controller just before you provided me the ‘fixed maybe’ patch version, so I don’t think that can be the problem, because it is still completely unresponsive in the actual Audulus application. I guess I can do some stuff in the AU, but a lot of my capabilities feel like they are clamped down because the AU is foreign in comparison, and also aren’t there some big limitations of the AU vs. using the full version for different channel routing and such? The AU feels like trying to accomplish tasks in LibreOffice or some online word processor that only MS Office suite was capable of handling back in the day when MS ruled with an iron fist. This is such a huge bummer :frowning_face:

Update 12/2/18 - 1916 Hrs. CST

I was wrong. Upon further examination and testing since making this post, I discovered a few movable parts of the UI are able to respond to CC events after learning the channel they are to use (level, knob, toggle switch nodes all were tested working in my patches). So turning pots, hitting keys, pads, fader, etc. are all working. It is the actual overall Audulus application that is not currently working to output sound or give any indication of having been interacted with when any of the control events are happening.

I made a new test patch to test this theory after 3 more uninstall/reinstall cycles, and I have included the screen capture of the strange outcome. I set the toggle, clicked it once, which should make a persistent sound, but there is nothing from any audio output. Also, I noticed that I was having absolutely zero CPU time used by any patch, which seemed more strange, so I enabled the CPU time indicator when sound should have been coming out. I will include the patch below in case I made a mistake in my haste to try and fix this issue.

Please let me know if anyone has any other suggestions about this. Part of me wants to disable the SIP on my Mac and go digging through the inner OS application files to see if maybe there's a cache that needs to be cleared somewhere under the /var/private dir, where I am unable to go without making OS security modifications. We'll see how desperate I get to make this work. Thanks in advance for any other suggestions!

Sound Test.audulus (1.7 KB)

The real worst part of this is that Audulus is my favorite app and I have been learning so much and getting a great sense of accomplishment and enjoyment from it since I bought it, and without a working MIDI input, I feel like I’m basically dead in the water, as I had blocked off my whole day to work on patches and experimenting with sounds today. I am not aware of a way to do that with any other medium. Not in a way like Audulus, anyway. This is how great your application is, @Taylor and @biminiroad; I am full of crushing disappointment upon realizing that I cannot use it. Thank you for your hard work on making it a reality for us :slight_smile:

1 Like

I cracked the case. 17 uninstall/reinstall cycles, deleting Logic Pro, disabling SIP and going full nuclear wasteland with all of my remaining Audulus configs and dependencies that remained, just in case so I was sure it would be a fresh install when I put the app back on my Mac, none of it mattered. I was about to throw in the towel, but decided to check on one last thing that seemed unlikely to me.

It turned out to be the last place I would have ever thought to look again: the MIDI device config, obviously right under my nose the whole time. The problem was an aggregate output I had created to make REAPER work correctly, according to their instructions. I never would have guessed that bundling my machine’s microphone with a speaker set as a group would make Audulus freak out and lock up, but now I know, and if you’re reading this, so do you.

Conclusion: Audulus DOES NOT play well with aggregate microphone and speaker groups

Thanks @biminiroad for your prompt replies in trying to help me through my issue :smile:

1 Like

Ah I’m sorry I didn’t mention that before - that’s a known issue. It’s actually a bug on Apple’s side. Good to know it’s working again though!

1 Like

Just curious why you needed to create an aggregate device for Reaper? I’ve been using Reaper for ages and never needed to use an aggregate device.

3 Likes

@stevo3985 So sorry about this. Because of this thread, a friend and I filed another bug with Apple (using his account) about the aggregate device issue (his project also uses the code with the bug in it). So hopefully the additional bug will elevate the priority and they’ll fix it. I filed my original bug back in March.

They made some progress at least, because it used to crash, now it just fails to start audio.

I could get around this bug by coding to the lower level audio APIs, but it would take maybe a week of work, and would need separate implementations on iOS and macOS.

2 Likes

Now that it no longer crashes, perhaps what we should do for now is pop a dialog saying that Audulus doesn’t support aggregate devices. Looks like we can detect them: https://stackoverflow.com/questions/10276505/how-to-check-if-an-audio-device-is-an-aggregate

2 Likes

Not your fault at all, the symptoms I was exhibiting were very strange to say the least, and I would never have guessed that was the case, were it not for me trying to resolve it in every other way I could imagine for 9 straight hours. I do not give up when a problem is presented in something important to me :wink:

I don’t know the logic behind it, but this from the official REAPER user guide I used for setup ~1 week ago:

Please don’t create more work for yourself; we can survive without it, imo. That is why I put the time, effort and detail into this forum post, in hopes of helping others if/when this comes up again. You guys have made and promoted a killer product and community of followers that I have come to revere and depend on to further my musical ambitions. I am super grateful that you have put so much into making this app/community in the first place, as stated in a previous comment. :slight_smile:

If this is something you could easily build into the app, I think it would probably benefit other members that are not tech obsessed engineers with nothing better to do on a Sunday afternoon, unlike myself lol. I am certain that most people would have given up long hours before I was willing to do so, and for the sake of those people, if you built in a dialog, I think it could save them a lot of time and frustration, in case they are not yet members of the forum or just don’t happen to search the right string to match this post with google or whatever.

1 Like

I’m using a FocusRite 6i6 audio interface, so I never ran into this issue. You might try using or check the box for “allow different input and output devices” in audio setup in Reaper as a work-around when using Audulus. Hopefully Apple will see fit to fix the bug soon.

1 Like

I appreciate the advice, but it was actually residual leftover from a week ago when I was torn between REAPER and Logic Pro X, and I ended up going with LPX because of a small hangup with the former that I wasn’t willing to endure and find still yet another workaround for my workflow, knowing that Logic would ‘just work’ with my setup. That was the level of my on the fence-ness, so I quickly bought the latter and haven’t looked back. So I had done all the setup, and then ended up removing it, and forgot to get rid of the aggregate device, which was no longer necessary, but I took care of it last night when I figured out the issue

I’ve grown quite fond of Reaper as a DAW. It’s very flexible, efficient and quite stable, however I’m in the process of migrating to Ableton Live. My son has been using Ableton for a while and I had a “Lite” version which came with the Focusrite. I decided to use it for my last project and I liked the Ableton workflow. As an early Christmas present to myself, I splurged and bought a Push 2 /Ableton Live Suite bundle. It arrived yesterday, and I’ve been busy playing around with all the included stuff. I’m looking forward to diving into Max as a complement to Audulus.

2 Likes

I played around with Ableton Lite, and I will probably circle back as my skill set grows in the future, but the full version of Ableton Live was far too expensive for me to consider as a reasonable option at this time, for many reasons. So I narrowed it down to what was best for me, and I chose Logic. I am quite happy with it, and I feel like Audulus makes it even better. :slight_smile:

Yeah, I know what you mean. The high cost was what put me off Ableton initially. Reaper was much more in my budget range. In fact Logic was also off the table for cost reasons. Logic is very well respected and as a traditional DAW, I doubt that Ableton would really offer any advantages over Logic (or Reaper for that matter). I was attracted by Ableton’s session workflow and the inclusion of Max for Live.
BTW if you have an earlier version of Lite, Ableton has released an update to 10 Lite which is free for existing license holders. Actually quite useful, but the 8 track limit was a problem at times. I found myself sketching out ideas in Ableton, then moving to Reaper for a final mix. No particularly efficient. I’m hoping that my investment will pay off and I won’t end up with a case of “buyer’s remorse”

I’m having trouble actually detecting an Aggregate Device (Apple’s APIs are totally undocumented, and the best I can do is find snippets around the web), but I can detect when audio fails to start and pop this message:

3 Likes