iPad Pro 10.5” Microphone and ADC Nodes - No Signal Coming In

Edit: This is not an actual issue other than operator error. If you are having the same issue, see @espiegel and @stschoen suggestions. What I have to say is not really all that important unless you would like to have a laugh at my expense for being dense and cocky in my analysis of this situation from the start, and I certainly should know better. Anyhow, lesson learned, and big ups to these guys for their replies that helped me narrow this down. :smiley:

I have been noticing an issue with my 10.5” iPad Pro for about a month that I hoped would go away with the upgrade to iPadOS (iOS 13), but it still persists, so I wanted to mention it officially. The microphone and the ADC nodes used in many different patches are not allowing any signal to pass inbound.

At first I thought my microphone might be broken on my iPad, but when I switch to Gadget to use Zurich Recorder, and also when I switch to GarageBand and use the sampler, there is no issue with any sound input. I was hoping by posting this - a) others can tell me if they have the same issue with their setup, and b) hopefully someone smarter than me can figure out what is going on and fix it.

This may be an A3 issue, but it also could just as likely be an Apple issue, as the aforementioned nodes work fine on my iPhone and my iPad Air 2 (which was upgraded to beta-iPadOS months ago for some development testing). Anyhow, I just wanted to mention it in hopes of getting a bug ticket going for this, as my Pro is my main audio production device, currently, and I have been hoping to use external audio as a modulation source for my builds and cannot. I also am not able to utilize the Vocoder that @stschoen built and provided me a while back.

Some examples for others with similar setups are included to test with below:

16 band vocoder V1.1.audulus (1021.4 KB)

iPad Pro ADC Trouble.audulus (903 Bytes)

iPad Pro Microphone Trouble.audulus (1.2 KB)

Have you tried a different audio interface? Also are you using headphones? If the mic is working in other apps it’s not hardware

1 Like

Yeah, sorry I didn’t mention that. I have tried using multiple different types of microphone inputs, from the base external to every single pair of headphones (EarPods, AirPods, Beats wired and wireless) that I was able to get my hands on. No dice for me. I thought perhaps it was universal to iOS, initially.

It was further frustration when I opened my iPad Air 2 after I had mentioned it to you personally, @stschoen and you pointed out that it was working for you, and it was then found to be working with all the devices I only use passively for other tasks. My iPad Pro is the newest and most capable device I have, and I therefore thought I could count on it to be my main audio device, while transitioning from state to state. All my other hardware was packed in boxes and got shipped on its way to Washington state yesterday. Just my luck, huh? :joy:

Assuming that everything is on the same release of iOS, if the Audulus ADC works on one it should obviously work on the others, but Apple has made changes in the underlying ADC hardware from time to time. The iPad Pro probably uses a different ADC than the Air 2 so it could be some subtle difference in how iOS treats the “real” ADC. What I was wondering was, have you tried it with any other external audio interface. Using different ADC hardware would help determine if the internal ADC/software was the culprit. You can pick up an iTrack Pocket from Amazon for $15.


It’ll give you an instrument input and a pair of stereo mics. It works with my Air 2 so I assume it’ll work with your Pro. It would give you an alternative ADC to try. It comes with a short microUSB to lightning cable, but I typically use it with a standard microUSB to USB cable and the Apple CCK so I can power my iPad. Of Course on the Air 2 I use the headphone jack for audio out. Audio out would be more difficult on the Pro although you should be able to use studioMux or similar to send it to your Mac. In any case it’s a steal at $15, I paid $95 for mine. When Apple removed the headphone jack and changed the size of the iPhone, the phone no longer fit the Pocket so the price dropped (at least until they’re gone).

1 Like

Have you checked your system settings to make sure you gave Audulus permission to access the microphone?

Have you tried using AUM or Audiobus to send the mic input to Audulus?

2 Likes

@espiegel123 I appreciate you chiming in. As a support engineer who has dealt with this type of troubleshooting daily for more than 4 years, initially, I was taken aback, like, “does this guy think I am an idiot? Why would he suggest that to me? Of course it is enabled, that is one of the first things I make sure to set for all of my audio programs.”

However, in the name of the scientific method and good, thorough testing processes, first I plugged in my OP-Z, which has the capability to be a different audio interface, as @stschoen suggested and got nothing when it was plugged in through CCK with the microphone activation button pushed. Then I followed up with opening AB3 and setting up routing the audio to A3 from the OP-Z microphone chosen as the input explicitly…and got activity in my scope display for inbound on the ADC for channel 1.

This made me feel like perhaps your suggestion was starting to hold water. So long story short is that I forgot about 6 months ago, I was having trouble pairing my Apple Pencil back to my iPad after it died one night and recharged, only to be ignored by the OS when I attempted to re-pair it. The end result of 2 hours of troubleshooting steps with Apple was a request to factory reset, after which a new unit would be warranty replaced, so I erased and started over and the pencil paired when all was restored.

When it restored, I must have missed the pop up when it asked for audio permissions again or clicked the wrong option when it happened, as when I navigated to settings to double check that I couldn’t be wrong about my assumption, there it was, not enabled, just as you had suggested. Good god, I am so mortified…

As such, I am never one to shy away from admitting I made a dumb oversight, and that is what this was. So like I said in the beginning of this post, “thanks for your suggestion” again, as I probably would have just continued sitting here thinking, “no chance I could have missed that” like the guy that calls support for the PSU being smoked, only to find out through the steps that he forgot to plug the darn thing in. What an embarrassment, smh :man_facepalming:

2 Likes

I once drove 3 hours to deal with a bad display only to find out the brightness was turned all the way down. Sometimes it’s the simple things that are the hardest to find. :cowboy_hat_face:

1 Like

Thanks, Steve, that actually makes me feel a lot better to know I am not the only one that has done something like this :smile:

1 Like

Glad it worked out. We’ve all been there. Even the most technically savvy occasionally overlook things.

1 Like