Bug: iOS - Audulus does not function if I minimize audulus and open other apps

Hey, is this a known bug or am I only experiencing this issue, are there others having this exact same issue?

When I open Audulus it works good, now if I press the home button to open another app and then reopen Audulus, the oscillators no longer oscillate, and other functions completely stop working (among many other issues I am sure of). The only way I can fix this issue is by swiping up from the iPad screen to close Audulus and re-open it, but having to constantly do this by app switching becomes quite a nuisance after a few times.

I have another issue, I’ll post it here as I don’t want to create two threads, as it is somewhat of a similar issue.
When I create an oscillator using the phasor node with a waveform node attached to the phasor and having added the correct mathematical expressions for creating a sine wave, I am not getting any output out of the phasor, no waveform, nothing. I even created one exactly as the one Robert Syrett (I apologize if I spelled his name incorrectly) has created for us, and I still can’t get an output, I have even tried restarting the app, and still nothing.

Using iOS ver 12.0.1

I’ve bumped into this problem quite often, and have also found that the only way to solve it is to quit Audulus and start again. Quite frustrating to say the least. One could look at the positive side of it and take it as something that keeps you totally focussed on Audulus without being tempted by all the possible distractions the iPad has to offer :blush:

Working ok on my Air 1. Do you have background audio optioned on?

I agree with you on the distraction part, sadly I was doing it for other Audulus purposes :stuck_out_tongue:, but you’re absolutely right.

You know what, I had a feeling that this is maybe something to do with it. As apps that have audio recording usually run when the app is minimized. I am going to have to take a look at the Audulus settings on the iPad when I get home from work.

It is a known problem triggered by the background audio option being on in combination with leaving Audulus and coming back.

Btw, you can load Audulus in AUM or Audiobus ir another host in order to record it without background audio being on. (I think)

For the issue where Audulus is stopping, have you enabled background audio in settings? (It’s the wrench icon in the upper left corner). I see the same problem on my iPad AIr2 if background audio is off, but turning it on seems to help.
As far as the phasor is concerned, bear in mind that the waveform node is only useful at low frequencies (around 1 Hz). if you run it a audio rates you won’t get a very useful display. The phasor node outputs a 0 to 2 pi ramp so all that’s needed for a -1 to 1 sine output is an expression node with sin(x).

1 Like

Thanks guys for the help, the background audio option fixed the issue.

Yeah, I have the sin(x) expression connected to the output of the phasor and the input of the waveform but it’s not showing a signal.

Edit: Sorry, I should also clarify that, I have the expression exp2(o)*440 as the input of the frequency of the phasor

Try using 0.5 as the frequency input and see what you get at the output of the phasor. If you divide the phasor output by 2*pi, you should see the ramp in the waveform display. Your o to Hz conversion is fine so it should work.

1 Like

Excellent, worked, thank you!:grin:


I completely forgot about the background audio setting! :upside_down_face:

Good to know that someone else has been helped from this thread!

Developers tend to leave the background audio function off as a battery saver. It is also not needed if you use the app in AB or IAA. I tend to turn it off for all apps and always double-check the settings in anything new I dl.

I have no issue turning it off when I am out of the app for a few minutes and turning it back on, quite grateful actually, as simple as that is

1 Like