Ableton Live 10 - AU Beachballing Issue

I’ve been using Audulus 3 on iPad for the last few weeks and decided to take the plunge and get it for MacOS. It works fine as standalone (I think its V 3.6.1).

So I DL’ed and installed the AU package via link in the software. Logic Pro X recognises and loads the AUs ok (there seem to be 3 - right? what’s the difference?).

However if I load the AUs in Live 10.1…I get a wonderful spinning rainbow beachball and then I have to force quit the session. It’s a showstopper…

Ideas?

[MacOS 10.14.6. Mid-2015 MacBook Pro Retina]

I’m running Live V10.1 on Mojave 10.14.5 and I can run the AU without beach-balling. I have noticed that the new clamped knob does not appear in the AU. I’ll update to macOS 10.14.6 and see if that makes a difference. Are you beachbaliing with no patch loaded?

I updated my Mac to Mojave 10.14.6 and the AU is still working. The standalone version won’t operate with a composite audio device, perhaps it’s a problem with your audio setup. You might try setting your audio device to the internal speaker and mic. Also check that your sample rate is set to 44.1 KHz. The current standalone version will operate at other sample rates but I’m not sure about the plug-in. It hasn’t been updated for a while and is running an earlier version of the code. It’s slated for an update when version 4 is released, hopefully later this year.

I’ve only tried with Mac’s internal audio (mic/speaker) as I/O at 44.1kHz in Live 10. Beachballing commences almost immediately after instantiating the audio unit on a track, no patches loaded.

I’m actually more interested in the AU than the Standalone. I probably should have done more research before jumping into purchasing the Mac version but I was pretty impressed with the iOS version so was a bit blindsided.

Does the stand-alone run OK? I’m a bit mystified with your experience with Live. I know that there have been some issues with Logic Pro but I’ve never had too much trouble with Ableton. Have you tried a different audio interface? I do have one Live set with 5 instances of the AU that crashes when you try to close it but other than that the AU has been pretty stable. I assume that you’re instantiating the AU in an otherwise empty set. Since it beachballs before you load a patch, It’s obviously not patch related. Since we’re running the same versions of macOS and Ableton there must be some differences in our setups or hardware that’s causing the issue. I’m using an iMac 27". My Macbook Pro died in 2017 and I haven’t replaced it. I did have some issues with the Macbook’s graphics hardware and Audulus, but that affected the standalone version and was ultimately fixed in any case. You might want to drop a note to support@audulus.com if you haven’t already done so.

Standalone seems to run (at any sample rate) without a single issue.

With Live 10 I was instantiating in a new set with nothing on any tracks…only default send effects. To add intrigue to this debacle Logic Pro X has succumbed to the same beachball fate as Live 10 last attempt to use Audulus as an AU instrument.

Thanks for your help! I’m going to try support@audulus.com for this one.

So I got in touch with Taylor who swiftly and skillfully diagnosed the issue.

It seems the beachball problem was related to a graphics setting. Earlier this week my MacBook’s battery and trackpad needed to be replaced and I had a few follow-on issues that led me to reinstall MacOS in recovery mode (It was the same day I purchased Audulus 3). I reinstalled MacOS in recovery mode and this probably changed my graphics settings.

So I deactivated ‘Automatic Graphics Switching’ in ’System Preferences / Energy Saver’ settings (it was active by default I guess). This seems to have solved the issue for now in both Live 10 and Logic Pro X. I hope this helps anybody else if they encounter the same issue.

Big thanks to Taylor and stschoen :slight_smile:

1 Like

Interesting. That was the same problem I had with my 2013 MacBook Pro. In my case it was with the standalone app and @taylor fixed the problem in the standalone code. I guess the fix didn’t make it into the AU. I’m surprised that the issue still exists in the 2015 model. (I thought I was the only one with the issue). If you want to switch the setting manually there’s a free app called gfxCardStatus that will display which graphics mode you’re in and allow you to switch on the fly. Leaving it set on the discrete GPU all the time runs the battery down pretty quick.

The more I think about it I do recall hearing of various plugins having issues with crashing due to graphics settings. I’ll give the switching tool you mentioned a try when I get a chance. My MacBook is fritzing in and out at the moment — Battery, Trackpad issues…just what I need :expressionless:

The AU version of Audulus currently uses OpenGL as its graphics engine. When the plug-in loads and attempts to display its UI the MacBook tries to switch from the integrated GPU to the higher performance discrete GPU and for some reason this causes the hang. The current standalone version uses Apple’s Metal graphics engine as does the iOS version. The version 4 AU will also use Metal so this should be a temporary problem. I used the app to switch to the discrete GPU before loading Audulus. That way I avoided the hang but could switch back to the integrated GPU to save battery. It has a handy menubar icon which displays the mode you’re in and allows you to switch.

1 Like

Just for the record, I tried gfxCard Status. It caused some issues. Number one, it wouldn’t really let me select the individual graphics modes from the menu. Number two, if I then tried to use it in dynamic mode (suggeste by the developer) it would force the GPU to change when I open Audulus in Live (to the one that makes beachballs appear). Uninstalled and back to previous fix – no issues :slight_smile:

1 Like

Sorry you had issues. It worked fine for me.

No worries – just letting anybody who may follow the thread know :wink: