Problems with autosave, Ipad pro 12,9 first gen (A1584), ios 11.2.6 (15D100)

Do you have developer reports turned on for your device? The crashlogs would be helpful in tracking this down. Especially if you can crash it several times in a row.

1 Like

I have the report of the crashes. I can’t upload it because the file format isn’t supported by the forum. Can I send it to you by email? Or should I copy/paste it in the message?

1 Like

Oh awesome thank you! Can you email them to support@audulus.com?

1 Like

Done!

1 Like

Thanks! @taylor told me to ask you if you’re having similar problems with other apps. Like maybe open Notes and try saving a large text file of copy/pasted Lorem Ipsum text into it (like 10 pages worth) and see if the file gets corrupted or it crashes.

Also any trouble you find with other music apps you’re using with file saving? There’s a small possibility it might be a hardware issue.

Also, how much storage is left on your iPad? Are you close to full?

http://generator.lorem-ipsum.info

1 Like

No similar problem with other apps. I tried what you said with Notes and it works fine, no crash.

I have 200Go left on my IPad.

I was surprised when you told me this issue was addressed months ago because really it feels like the same issue I had for a while with Audulus (the only real issue I have with it actually).

I noticed it really happens on big patches, with several delays, oscillators, filters, exp nodes, and possibly two stereo output nodes (not mixed into one).

Could it be because I re-open the project to soon? I mean, if the patch is big, maybe it takes more time for Audulus to save it, and if I re-open it just after closing it, maybe it’s conflicting with the saving process?

Honestly I can’t remember if all the times I experienced this problem were when I opened the project just after closing it. I will pay attention to that in the future.

As I said I have same issue with complex and not so patches. I cancelled icloud sync to avoid such problems, but it didnt help. I have more than 100gb free space and everything is up to date. Now Im not sure what is bug fixing proccess within Audulus team. What should I do to help? Or maybe it is not so actual, because Ipad Pro is not so popular…?

Hey! I just wanted to chime in - I’m a new Audulus user and have unfortunately experienced this same issue a number of times over the weekend as well.

Current setup:

  • 8" iPad 2 Mini (32GB)
  • iOS 11.4 (15F79), recently reinstalled from scratch
  • Plenty of HD space, CPU usage is reported as typically no more than 30-40%
  • Typically Audulus is the only application running, maybe Safari alongside

It also might be worth noting that each time this issue occurred I was on an airplane without any network connection (so patches were marked “Waiting to Upload…” to iCloud), and had been reopening large-ish patches relatively quickly as mentioned above. Additionally, when the problem happens, I typically see a generic iCloud document icon instead of the patch thumbnail.

Unfortunately I don’t have any patches to upload as I deleted them since they lost a decent amount of work :confused: I’ll be sure to attach anything if the issue continues, however. Let me know if there’s any other information I can provide and I’ll do my best :slight_smile:

(Also, because this is my first post here and I don’t want to seem negative - I love using Audulus so far! The app is incredibly well designed and works/sounds amazingly otherwise.)

2 Likes

I was just going to report the same problem.

I currently have a connectivity problem that causes occasional bit-rate dropouts (no streaming in working right now, although low data rate activities are working, albeit more slowly than before.)

I have had problems with backing out of a patch to open another Audulus project. I’ve had my changes disappear and I’ve had the application hang. It’s happened on the simplest, tiniest, projects and it’s happened on my really big ones as well (for instance, I lost tons of work on a UI I’m building just 20 minutes ago, and the project at this point consists maybe 20 patch ins and outs and lights, with nearly zero innards)

I am guessing that Audulus auto-save periodically, or with each change. If so, it does it without indicating it’s doing it. So, my theory is that I’m losing work because I’ve closed my project before I’ve given Audulus time to complete auto-saving.

Does this sound right? Is it possible to delay the closing process if the user is attempting to close a project before it’s saved, or can it save locally and mirror on cloud at its leisure? Can a little “awaiting save” icon pop up when unsaved changes are present?

OR, am I missing an option to work locally until my connectivity problem is solved?

1 Like

Sorry this is happening to you!

A couple things to narrow this down:

Are you using iCloud? If so, try using it without iCloud (save directly to your device) and see if the problem persists. If it doesn’t, then there’s something wrong with how it’s getting uploaded to iCloud (which might make sense due to your spotty internet). If not, then it’s something to do with the saving itself.

If you go into the Settings app, you can find Audulus and adjust where it automatically saves from iCloud to Local Storage.

Can you try that and get back to me with the results?

Oh man, I wish I’d have read this hours ago. I just a really productive afternoon to the same problem. My interface was done. I was just about to upload it.

Yes, I have been using iCloud. I didn’t know there was an option. I’ve only seen “allow to play background” on the app settings.

I need to go take a walk…

1 Like

Found the settings you referred to. Will take that walk, then try it.

Took the walk. Made the changes. No problems. I’ll start working local and just put on cloud when I’m ready to share it (Which I am.)

Of course, I know the old saying about absence of evidence, but I take this as solved for now!

I am not alone with automatic saving issues. Because it cannot be saved automatically because the iPad crashes. I don’t know if this happened to all iPad models, I use the iPad mini.

Does the iPad itself crash (shut down) or does Audulus crash? If it crashes, does it crash to the background (remains open, can see it in the app switcher) or does it completely kill the app.

Would love to help but just need some more info - also are you on the latest iOS version as well as latest Audulus version? Thanks! :slight_smile: