KM BopPad Clean Interface

I have posted a few configurations for the Keith McMillen BopPad. A polyphonic drum trigger module with velocity was posted here and I think it is an improvement on the other patches I had.

Here it is adapted for the BopPad with four example voices.

BopPad Module.audulus (343.2 KB)


Nice selection of percussive voices and clever use of the mod wheel. :cowboy_hat_face:


I stripped back some of the functions on the Korg Mono/Poly Snare and substituted it for the noise snare.

BopPad Module.audulus (297.0 KB)


Just reconnecting a bunch of stuff. I have my midi keyboard flashed to 16 and my BopPad flashed to 15. The BopPad is only working in OMNI with this patch and only the bottom two quadrants are firing. Any ideas? In other words, when I try to assign the BopPad module here to 15 I don’t get a signal.

Oh no…okay, it looks like it’s the BopPad. I tried it with a bare midi module and had the sam behaviour. All four quadrants work on OMNI legato. That’s too bad my MacBook is down and they haven’t created an app to flash it on ios. We have been begging for one for a couple of years. :pleading_face:

They have a web editor. But not compatible with iOS. Anyone in know how to hack it?

If you don’t already have it, MIDI wrench for iOS will at least let you see exactly what the bop-pad is sending. It’s free and it’s a pretty useful utility. You could try the Chrome iOS browser but it probably won’t work. iOS is pretty restrictive on app permissions. I was kind of in the same boat with my Korg nanoPad. For a while the configuration utility wouldn’t work with the version of macOS I had installed.

1 Like

Same here with my NanoKey Studio. Maybe now that Apple is moving in the direction of making iPadOS more like a computer, we will get more computer like apps to work with our hardware.

Yes I do have MIDI wrench, it’s fantastic. Looks like the BopPad is no longer flashed to channel 15.

Need a way to hack in…there has to be a web app workaround. They have a web app.

Have you tried Chrome for iOS? If not it’s at least worth a shot. I’m guessing that they’re probably using MIDI sysex commands to program the bob-pad, at least that’s how most of these things work. There might be another way to send them from your iPad if we knew what they were.

I found this. It would be worth a shot as well:

Installed Chrome on iOS. Tried the web midi link and got the error above.

With the WEb MIDI Browser app, I was discouraged by the reviews on the App Store page. I figure, if it really worked and it’s that old not only would there be more and better reviews, the Keith McMillen forum people would have been on it. I did give it a whirl and nothing seemed straightforward.

For now I would say forget about it. I think time will resolve it. Seems like a dark rabbit hole. Right now I think I should focus on other aspects of sound design and music production. I’ll just have to get my MacBook up and running again.

1 Like

Well it was worth a shot anyway :cowboy_hat_face:

I just wanted to make a point here about gear. It has been a year that I had this non-functioning BopPad issue. My MacBook was not working (which was why I was trying to find a workaround on iOS for the web editor). It turned out that the brand new knock off magsafe cord was the issue. I had replaced the battery, and thought maybe the cord socket was the problem. Once I got the Macbook back up and running with an Apple cord I could see the BopPad wasn’t working. I sent it back to the manufacturer. They sent me a replacement unit. So, one year later I have resolved the problem.

I thought I would share this because I have many problems with my gear, but I refuse to let it keep me from making music and I keep tinkering away trying to solve issues. I know many of you must have similar issues, let alone the hardware interfacing challenges and software concerns. Sometimes it takes a year! :man_shrugging:t3:


That’s awesome man! I’m glad to hear you were able to get the MacBook Pro back up and running! :smiley:

1 Like