Audio-in FX pedal board

I made this ‘pedalboard’ with most of the cool fx modules I tested, with simple bypass switches for each.
Easy to use for someone who wants to try Audulus for audio-in processing, like me :slight_smile:

Edit: Optimized, added spigot nodes and reduced idle CPU load to around 15%.
Edit2: Further optimized, brought idle CPU to 4%. Put some output level controls on Blobulator and the fold processor. Added some modulation sources, including Uncertain Future stuff from stschoen

Download: FX1 board.audulus4 (777.4 KB)


2 Likes

Ah this is super cool! I tried this in A3 and found it too CPU heavy for me but with the spigot node in A4 to cut down CPU it should be totally doable. Great idea!

1 Like

Didn’t actually use spigot here but that is indeed a good idea :stuck_out_tongue:
I’m just lucky to have a powerful ipad pro so didn’t mind the CPU.
Thanks for the input

1 Like

Yeah, it’s actually crashing my iPad Air at the moment so I can’t give it a try with my hardware :sweat_smile:
Inspired me to revisit my own tho!

I’m trying to use spigots but I can’t seem to get it to work to stop processing for bypassed modules.
Connected as per the documentation.
Maybe someone can help.

1 Like

Can you upload your patch? The issue is probably related to there being meter nodes (e.g., lights) that prevent the module from “sleeping.” The spigot node is more used internally rather than externally with modules, though we have talked about making them somehow work with modules as well.

PS: Thank you for your nice review in the app store!

I see :slight_smile:
I did upload the patch, did I not? Link is above the image.

Of course I made a nice review for such a nice creation!

1 Like

Yes, I just don’t see anywhere where you used spigot nodes, I figured that was in another patch?

Also, I looked a little closer

Screenshot 2022-12-28 at 11.29.11 AM

Mixing like this doesn’t preserve stereo, if that’s what you were going for? Maybe you weren’t, but just checking.

Oh right, didn’t upload the one with spigot testing. I just tried inserting some spigots and couldn’t get the bypassed modules to say ‘inactive’ or drop CPU.

Not trying to preserve stereo! Wanted to sum to mono. I used the mixer before I found the sum :stuck_out_tongue: Learning as I go here

1 Like

Yeah if you just inserted the spigots in between modules, that would make sense that it didn’t work. You’d need to get rid of every module’s meter-class node to stop all processing. It would be kind of a chore to do that, which is why we’re talking internally about how to implement the spigot node in a way that allows you to switch between modules like that as well.

Anyway, I hope more people start doing this! Especially those who have MIDI foot controllers, this can be like creating your own custom digital collection of effects but with much more advanced signal routing and modulation than you could with anything commerically available.

1 Like

Ok I understand! Yeah I’d very much like some sort of module spigot option to limit CPU waste for a ‘board’ like this :smiley:

Absolutely, I feckin love the idea of building modular fx with ipad, right inbetween software and hardware, without me spending thousands of bucks on physical modules…!
Recommending to all my musical friends.

1 Like

Thank you so much! We’ll post updates about spigot changes here and on Discord if and when they come.

Also really appreciate spreading the word - it helps us a lot to get new users and grow this great community :slight_smile:

1 Like

Updated the patch, put spigot nodes as per the instructions, dropped the CPU a whole bunch :slight_smile:
It was indeed a chore, haha!

2 Likes

Hey @biminiroad can u tell me why the Fairy hum reverb isn’t working in this?

Would need to see an example patch

Yeah the patch I’ve uploaded here :stuck_out_tongue: Fairy hum reverb is in there

1 Like

Ok, I found it and see how you modified it - can you tell me a little more about how it’s not working? Like no sound is passing? Can you see the sound going into it and then trace node by node where it gets blocked internally?

It never worked actually, before or after me putting spigots in. Unlike the other effects.
No sound passes when the effect is on. I don’t know why.

But you can get it to work in another patch by itself? I’m trying to narrow down if it’s a problem you’re having with the module or the module in this particular patch. Thanks!

1 Like

No, what I’m trying to tell you by “never worked” is it doesn’t work i.e. doesn’t pass audio or effect when I load it (the module from factory library) in a new patch with audio in and out, it never has when I tried, it has been confusing, and I haven’t been able to figure out why it doesn’t work :slight_smile: