Multiple Headphones Clipping Audio

Hey everyone! I have been following the livestream tutorials that @biminiroad created a while back on the official Audulus youtube channel, most recently, Modular Synth 101. I got about halfway through, and I thought I was doing something wrong, as it was 3am this morning, and not wishing to wake the neighbors with my little jam sesh I had planned, I had gotten out my Beats Solo 3 wireless headphones and connected to my Mac before starting out.

I had noticed some weird audio anomalies that I wasn’t so worried about (ex. clicks, chords that sounded terrible, things that seemed like they might be due to user error in the setup phase (things I had also previously encountered on iOS with wireless headphones as well, but chalked up to myself not knowing completely what I was doing)), but when I connected my triple oscillator MIDI cascade to the mixer and then to the filter, it sounded so bad, I decided to give up as I had followed all the instructions, re-checked all my math expressions and checked the output numbers, and everything seemed to be just as the video displayed and exactly what Mark was describing.

I figured maybe in my sleep deprived state, I might be missing something that was the key, and so I went to bed and started again today. No headphones this time because I don’t worry as much about the neighbors during the day. Now, everything I set up sounds beautiful, just like in the stream, how could this be? I re-connected the headphones, played a couple notes, it seems to clip the peak of the attack of each note and cuts back in at the sustain phase and no problems with release.

This is really bothering me, and I tried to find exact audio specs about the headphones, and see if there could be some kind of definitive information that I could find to tell me why my headset was doing this. Then I tried another set of headphones, this time, some wireless Skullcandy Hesh 2 headphones. Same result as with the Beats.

I don’t have any wired headphones to try at the moment, but I am sure hoping this is something I can remedy in some way as this will seriously limit my ability to test and develop patches while I am not at home if only my computer speakers will provide reliable sound. I will include my half completed patch below for reference. Can anyone provide help, advice, insight, etc.? I will settle for any one of those three things, but if possible, I would love to have all of the information so I can better understand what is happening here. Thanks guys! Mod Synth 101.audulus (10.3 KB)

1 Like

From the example patch you have going, it seems like you’re missing a PolyToMono node at the end before your speaker node. You always want one of those between a polyphonic signal and an output. Not adding this will probably cause some clipping since you’ll exceed the maximum -1 to 1 output range of Audulus. 4x oscillator signals that are all -1 to 1 mixed together will become -4 to 4 - well above clipping range! :slight_smile:

1 Like

Thanks a lot for getting back to me. I actually got so excited when I read your reply, and I was sure this had to be it. I made the change immediately and eagerly pressed the middle C key to start my test…unfortunately, both are still clipping. I even threw in my Air Pods as a test subject on both my Mac and my iPad, and I tested each set on both iPad and Mac. Everything that connects via bluetooth is clipping with this patch. I don’t understand it at all, but it is extremely discouraging to be getting these results. Do you have any other ideas for potential explanations or fixes? I’m really hoping that my idiot brain is just snoozing on something obvious, and that this is not an overarching theme with bluetooth… :confused: Mod Synth 101.audulus (10.5 KB)

1 Like

update: So I have narrowed it down and it seems to be the filter that is causing the clipping to occur. I have no idea why it is happening to all my bluetooth headphones and not my external speakers, but because of what the ‘Synth Secrets’ article @biminiroad and @fferreres referred me to said about filters not only filtering the given range, but also changing the characteristics of other frequencies passing through, I thought perhaps if I bypassed it, things would be different. Sure enough, the clipping is gone, and I can turn the volume up and hammer the keys until my ears hurt, but as soon as I re-introduce the filter, everything goes pear shaped. I feel good knowing this, but if anyone can explain why this occurs, I would still really like to know. Thanks! :wink:

1 Like

Audulus Bluetooth Quality Fix!!!

I finally figured it out after obsessing over the issue for the last few days! This might be useful for other users too, which is why I am posting the solution to my issue. I should also mention, I have only figured out how to fix this on Mac, as I am not aware of any way to force a codec change or put a headset in output only mode on iOS (Perhaps this could be a feature that Taylor can include in a future build of Audulus?).

So the quick answer is to follow the instructions here: Bluetooth Force Codec.
For anyone with output only headphones, that should solve your issue. If you have a microphone too, and you’re still having audio quality issues, read on.

There was also one more step for me to take. The reason the sound was so terrible and clipping after enabling the above is because the headphones all have one thing in common: a microphone, which some people might wish to use as an input. The microphone makes the headset stick in a low quality codec profile (from what I understand) because it needs to use the same channel for input and output at the same time, or so it decides without informing you.

Navigate to System Preferences > Sound > Input and double click on the option for Internal Microphone and you will hear an instantaneous change. Your bluetooth headphones should now be in either AptX or AAC codec mode, and the quality issues will be resolved, barring some serious wireless issues you may have outside the scope of this instruction set. I hope this will help others, as well! :wink:

@biminiroad - even if I had figured out the codec thing, I would still be having issues, if not for your advice about polyphony. Thanks so much for replying and helping me to get this resolved! :smile:


Ahh thanks for that fix stevo! I didn’t know you were using Bluetooth headphones - should have asked. They’re currently not supported by Audulus, but it seems like this worked for you.

@taylor - maybe this fix stevo found is key to making Audulus work with Bluetooth headphones? More and more people these days are using AirPods.

1 Like

I’m happy to be of service! In my daytime life, I am a linux based IPTV support engineer, so fixing problems with A/V software and hardware, and finding workarounds is what I do best. Since it is not possible for any one of us to know everything, I feel very strongly about the vital importance of everyone’s participation and sharing of what we have learned as that is what makes this forum a great place to go for knowledge and assistance, and it helps us all to continue learning and growing, collectively. I hope to be able to contribute back in as much as I am able to take away from the treasure trove of information here :grinning:

I also felt this could be an important breakthrough, based on macOS and iOS being the main platforms (from what I can tell, anyway) of the majority of Audulus users. Given Apple’s continued push to remove the headphone jack from [seemingly] everything, and with the release of the new iPad Pro having happened yesterday with no headphone jack, it seems like there’s no choice but to try and adapt to this growing trend and go wireless, if we intend not to switch platforms.

1 Like