Bug Bounty - Solve This, Get FREE Audulus Upgrades for Life!
  • Hey everyone! Audulus has a bug right now that is proving *very* difficult to track down - we need your help.

    If you can find reproducible steps for this bug, you will receive FREE AUDULUS UPGRADES FOR LIFE, and 10 free Audulus 3 codes to distribute however you see fit.

    It appears this bug causes the history portion of a patch to become corrupted. When you go to load the patch, it will look blank. But if you open the patch with TextEdit on a computer, you can see that the file is still *mostly* there.

    There doesn't seem to be a pattern of crashing that precedes this happening. Users report closing the file, coming back to it later, and the patch is suddenly empty.

    We are of course terribly sorry and sympathetic to anyone who has lost time working on a patch in this manner. We hope that you'll continue using Audulus, but just make sure you backup your big projects in multiple saves (duplicate patch is your friend).

    Some good news is that Taylor is going to rewrite the way the Audulus files are written so that they'll load faster and be much smaller. For example - the default module library is around 250mb, but with this new file format, it will be more like 1-2mb. Taylor suspects that this rewrite may fix this bug, but the rewrite will take a month or more. While Taylor does this, you can help find the source of the bug.

    This is what you need to do:
    1. Update to the latest version of Audulus.
    2. Create a patch - connect modules together, move things around, delete and undo - use all of the features you can in every combination you can.
    3. Pay attention to what you're doing as you're doing it, and if the bug happens, retrace your steps - ask yourself what you just did, what your settings are (iCloud on or off? Other apps running in background?), and try to make it happen again.
    4. Upload any and all "blank patch" or "broken patches" here as a reply on the forum, even if they are old. We only have about 5 examples of broken patches from users, but if we have more, it may help track down what's going on. The earliest patch we have is from October last year - if you have an earlier one, that might help us pinpoint when the code changed and introduced this bug.
    5. If you can get the bug to happen more than once and have explicit steps that we can follow to reproduce it, you win!

    This is what you don't need to do:
    1. Tell us that the bug happened to one of your patches, but you don't know what caused it.
    2. Report other unrelated bugs - send those reports to support@audulus.com and we'll deal with them individually.

    As you can imagine, finding and squashing this bug is top priority right now, and all feature development and unrelated bug fixes are on hold until we find it. THANK YOU for your help and understanding.

  • Just a question: is the bug cross platform, limited to as specific OS?
  • Sorry to hear this is happening, I will definitely do some looking. Is this iOS only so far?
  • The bug is cross platform - it appears to happen more on iOS, but that is probably just a factor of there being most iOS users out there. Thanks @SansNom @demcanulty!!
  • i will look out for it... but so far i didnt experience it at all.. win7 standalone and vst usage
  • Just curious, why isn't there a save-as feature in Audulus?
  • I have experienced this problem and also reported the bug to Taylor so he fixed the file for me but then it happened to me again two more times but it wasn't bothering me so much since it was nothing important. I know it is very difficult to investigate the problem from just 3 errors but I was thinking what similarity was between them. That time I had almost full iCloud so I suspect it couldn't save the file properly. Since I created more space on iCloud I haven't experienced any error yet. Will keep an eye on it and will update you guys if something new occurs.
  • Hi, i also experienced it creating a module on iOS i've sent the patches 2 or 3 times directly via the report button inapp.
    Unfortunately i've deleted them since so i cannot report here.
    Hope this will help tho.

  • I'll keep it if happen again now ;).
    Full support
  • I have had this happen only once.
    In my case, I'm 99% sure it had something to do with iCloud + an ungodly large undo history.

    I was working with my gigantor formant table module inside a patch I'd saved in iCloud. I'd accidentally pasted like 10 of those things into the same patch, but I'd only meant to paste one. I deleted 'em, then I saved the file and exited Audulus. Came back a few minutes later, and when I opened my patch it appeared blank.

    Being curious, I opened the file in a text editor and noticed it was in JSON (cool), and then noticed that the file was truncated in the middle of that ungodly large undo history (maybe a buffer overrun or something?).

    Anyhow, I just traced it back to where the history block started in the JSON and deleted it, then added the appropriate closures to make it legal JSON again, and it worked fine.

    Hope that helps!
  • ive been trying to generate a large undo history to try this but I dont have saving to icloud enabled. Can you share a file with a large undo history?
  • @Ymsey - thanks!

    @plurgid - glad you could save the project - that's been the go-to solution for repairing the patches so far. Could you tell where the patch was truncated? Was it at that exact point, or at some other?

    @diego898 - "Can you share a file with a large undo history?" Do you mean can you upload it here? Certainly!
  • wish I'd saved the original version of the file, now!
    It appeared to be truncated at some random point midway through the undo history.

    The JSON data structure was not properly closed because of the truncation, which I'm suspecting is why Audulus didn't know what to do with it. There was a huge amount of undo data prior to the end of file, and the data didn't appear to end at any logical point. Like it didn't close a data structure or completely end a line ... if I recall correctly it just stopped mid-line as if the buffer containing the file content was too small or something like that.
  • Hello! Just checking to see if anyone has a patch with a long history they wouldnt mine pasting?
  • @diego898 - yes, please! :)
  • Man, this is the first time I feel guilty about regularly clearing my history...
  • I think I ran into this bug a couple days ago.

    I hadn't looked at this thread yet tho.

    I don't use Audulus a whole lot, even tho I've had it for like a year. I'm pretty new to synths and music stuff, so I've been getting more immediate kicks from other apps. Coming round to Audulus tho.

    I downloaded a lot of the patches posted on this forum the first couple months or so that I had Audulus. But beyond that I really didn't do much at all in Audulus.

    A couple days ago I was looking at my patches in the main menu and I saw a couple that were just a weird line of text saying it was empty.

    The lifespan of those patches were basically
    -downloaded a year or so ago on an iPad3
    -tinkered around with for 5min
    -iMessaged to my iPad4 like 6mo ago
    -sat unopened until the other day when I noticed they were weirdly empty

    I think they corrupted not long before I noticed. One of the files was "JJT sequencer" and I'm p sure I remember seeing it's proper uncorrupted thumbnail in the days prior to the corruption, in this week that I've been messing around with Audulus more. Or at least I think I would have noticed earlier that they were empty patches.

    But at the time, before I'd seen this bug thread, I figured they were prob real old patches that got obsoleted by some update, and I just deleted them.
  • The cause of this bug has been found by Taylor - it has to do with iCloud truncating the history of the Audulus file. Taylor's solution is going to be to take out saving history between patch loads until he can find a bug-free way to implement it. You'll still have infinite undo while you have the patch open, but as soon as you close it, the history will be wiped (sort of like Ableton Live does it).

    Since no one here technically "won" the contest, I'd still like to reward people who tried to help - so


    please contact me at mark@audulus.com for a free copy of Audulus on the platform of your choice. It doesn't have to be for you - it could be for a friend. Just let me know! Don't reply here, just email me :)
  • Good news! So it was not affecting Windows users? At one point I suspected the iCloud patch saving and disabled it.
  • @SansNom - as far as we know, correct - it wasn't. I take it after you disabled iCloud, the bug stopped happening?
  • Well not sure. That was this killer bug that annoyed me for a long time. At some point I suspected an "autosave" or something. And then you said it was fixed. It's true that I haven't seen this bug happening lately.
  • Great news! No wonder I was never able to reproduce (couldn't use iCloud syncing - it was full)